Sa. Apr 13th, 2024

Joomla! 5.0.3 und 4.4.3: Detaillierte Änderungen und Verbesserungen

Sicherheitsupdates:

  • Joomla! 5.0.3 und 4.4.3 beheben fünf Sicherheitslücken, die in früheren Versionen entdeckt wurden. Diese Sicherheitslücken könnten es Angreifern ermöglichen, sich Zugriff auf Ihre Website zu verschaffen, Schadcode auszuführen oder Daten zu stehlen.

Die behobenen Sicherheitslücken sind:

  • [20240201] – Core – Insufficient session expiration in MFA management views.
    • Diese Sicherheitslücke könnte es Angreifern ermöglichen, die Sitzung eines Benutzers zu stehlen, selbst wenn der Benutzer die Multi-Faktor-Authentifizierung aktiviert hat.
  • [20240202] – Core – Open redirect in installation application.
    • Diese Sicherheitslücke könnte es Angreifern ermöglichen, Benutzer auf eine bösartige Website umzuleiten.
  • [20240203] – Core – XSS in media selection fields.
    • Diese Sicherheitslücke könnte es Angreifern ermöglichen, Schadcode in die Medienverwaltung von Joomla! einzufügen.
  • [20240204] – Core – XSS in mail address outputs.
    • Diese Sicherheitslücke könnte es Angreifern ermöglichen, Schadcode in E-Mails einzufügen, die von Joomla! versendet werden.

Fehlerbehebungen:

  • Joomla! 5.0.3 und 4.4.3 beheben verschiedene Fehler, die in Joomla! 5.0 und 4.4 gemeldet wurden. Diese Fehlerbehebungen verbessern die Stabilität und Leistung von Joomla!

Einige der behobenen Fehler sind:

  • Ein Fehler, der dazu führen konnte, dass die Medienverwaltung nicht mehr funktioniert.
  • Ein Fehler, der dazu führen konnte, dass die Installation von Joomla! fehlschlägt.
  • Ein Fehler, der dazu führen konnte, dass die Website nicht mehr reagiert.

Weitere Änderungen:

Joomla! 5.0.3:

  • Fügt die Möglichkeit hinzu, benutzerdefinierte Felder in der Medienverwaltung zu erstellen.
    • Dies ermöglicht es Ihnen, zusätzliche Informationen zu Ihren Medien hinzuzufügen, z. B. den Titel, die Beschreibung oder das Copyright.
  • Verbessert die Barrierefreiheit von Joomla!
    • Dies macht Joomla! für Menschen mit Behinderungen zugänglicher.
  • Enthält verschiedene weitere kleine Verbesserungen und Optimierungen.

Joomla! 4.4.3:

  • Stellt die Kompatibilität mit PHP 8.2 sicher.
    • PHP 8.2 ist die neueste Version der PHP-Programmiersprache.
  • Enthält verschiedene weitere kleine Verbesserungen und Optimierungen.

Wichtige Hinweise:

  • Joomla! 4.4.x erhält keine neuen Funktionen mehr. Es werden nur noch Fehlerbehebungen und Sicherheitsupdates veröffentlicht.
  • Es wird empfohlen, alle Joomla!-Websites auf die neueste Version zu aktualisieren. Dies ist besonders wichtig, um die Sicherheit Ihrer Website zu gewährleisten.

Weitere Informationen:

Zusätzliche Ressourcen:

Hinweis: Die obigen Informationen sind eine Zusammenfassung der wichtigsten Änderungen und Verbesserungen in Joomla! 5.0.3 und 4.4.3. Für eine vollständige Liste aller Änderungen und Verbesserungen lesen Sie bitte die offiziellen Release Notes.

WordPress Cookie Plugin by Real Cookie Banner